Using USB WiFi dongle or RPi3

wifi

#1

I found internal WiFi module to work not as reliable as I need (the signal is weak), and I try different USB WiFi dongles to see if situation improves. But I don’t know how to make RPi3 use the dongle instead of internal WiFi. Can someone please give a hint? I see both interfaces in ifconfig output:

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:fe:e9:04
          inet addr:192.168.100.86  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::c68e:ce50:9b9:646/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42582 errors:0 dropped:243 overruns:0 frame:0
          TX packets:17730 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15459569 (14.7 MiB)  TX bytes:3234844 (3.0 MiB)

wlan1     Link encap:Ethernet  HWaddr e8:4e:06:35:4c:c2
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:136 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

By now, data obviously goes through internal WiFi.


#2

If you edit your connection file in system-connections then you can add a config option under the [connection] section:

[connection]
match-device=interface-name:wlan0

You should be able to replace wlan0 with the name of the preferred network interface.


#3

Thanks!

Is there a way to edit a file in system-connections remotely, in resin dashboard console? I suppose there isn’t, but just in case if miss something…


#4

There isn’t a way to do that at present.


#5

@willnewton Unfortunately, adding match-device=interface-name:wlan1 to [connection] section did not route traffic to wlan1 interface; it still flows through wlan0.


#6

interface-name=wlan1 worked.