Unable to connect to TTN - RasPi

support
raspberrypi3

#1

I have read all the posts related to issues in starting up raspi gateways but cannot see anything similar to my issue.

I have completed a RASPI3 The Things Network gateway setup using this tutorial.

The whole setup has progressed perfectly until the absolute final connection to The Things Network which returns a simple error, but impossible to debug!

print (“Router:\t\t\t”+router)
TypeError: cannot concatenate ‘str’ and’NoneType’ objects

The only variation to the tutorial I carried out was during configuring the gateway on Resin panel. Previously Resin had ‘Environmental Variables’, which I presume are equivalent to ‘Device Service Variables’.
Any ideas where to start fault find this ??


#4

any ideas?


#5

Hello, we’ve recently split the Environment Variables section on the device page into Device Service Variables and Device Configuration. The tutorial describes adding two variables (RESIN_HOST_CONFIG_core_freq, RESIN_HOST_CONFIG_dtoverlay) that should now be added to the Device Configuration page > Custom Configuration Variables. RESIN_* variables are reserved and can only be managed in this page. Can you try that and see if it works?


#7

Thanks for responding,
I had followed the tutorial on this,
so RESIN_HOST_CONFIG_core_freq was input and set to 250 and RESIN_HOST_CONFIG_dtoverlay was set to pi3-miniuart-bt.
However, I noticed that both these variables had a status of ‘override’ for the Raspi gateway device, which I was able to correct.
Sadly, following a reboot of the device the same error is returned and the service is exited.

I should have mentioned before. The RASPI device has been connected to Resin service without any problems. This is simply a connection to TheThingsNetwork problem. Just for reference, this is using the Australian frequency plan AU915.

Any more ideas?


#8

Hi Resin engineers,
I have a fleet of RasPi gateways to deploy, and I am not getting very far with the first one! See gateway ambiguous failure code below.
Can one of the resin engineers give me an idea if you have had no problems with lorawangw previously, and this is likely to be a TheThingsNetwork connection issue (or any other known issues).
There must have been a big increase in deployed gateways since last month’s TheThingsNetwork conference in Amsterdam so any other issues identified would be useful.
Thanks

   Traceback (most recent call last):
    25.03.18 08:35:57 (+0800)  main    File "/opt/ttn-gateway/run.py", line 137, in<module>
    25.03.18 08:35:57 (+0800)  main      print ("Router:\t\t\t"+router)
    25.03.18 08:35:57 (+0800)  main  TypeError: cannot concatenate 'str' and 'NoneType' objects
    25.03.18 08:35:58 (+0800) Service exited 'main ......'