There was a problem uploading the images to the registry

support
raspberrypi3
network
docker
resinos

#1

I just tried to do a deploy but in the uploading step it failed with this error:

[Error] There was a problem uploading the images to the registry.
[Error] Debug info: unknown blob
[Error] Not deploying release.

It has been more than one time that I see this error. Then, I have to re-do again the deploy, and this is done from the first step since after that crash there is no cache available. The deploy process is a very time consuming process (approx. 1hr) and this kind of crash is really annoying.

What might cause that error, so I can fix it and get rid of it once and for all?


#4

Hi @dbeqiraj, how big is the image that you are trying to deploy?


#10

Hi @imrehg. It’s 1.69GB


#11

I just got this same issue! Did you ever resolve it @imrehg or @dbeqiraj


#12

Now I’m getting a different error:

[main]  Removing intermediate container 33f2acec6164
[main]  Successfully built 87eb93e6ddb4
[Info]  Uploading images
[================>                                  ] 33%[Info]  Still working...
[Info]  Still working...
[Success]  Successfully uploaded images
[Error]  An error occurred: ETIMEDOUT
[Error]  Not deploying release.

remote: error: hook declined to update refs/heads/master
To git.resin.io:user_name/project_name.git
 ! [remote rejected] master -> master (hook declined)
error: failed to push some refs to 'user_name@git.resin.io:user_name/project_name.git'

#13

Hi @pushtheworld did the original issue resolve for you if you mention that this is a different error now?

What application type do you use (classic / legacy / starter / microservices / essentials)? That 33% is suspect, based on what application you have.