The "Failed to install release agent" bug is back


#1

Just to let you know I have this message when using your debian:stretch image with systemd enabled :

Failed to install release agent, ignoring: No such file or directory

07.09.17 15:12:31 (+0200) Systemd init system enabled.
07.09.17 15:12:31 (+0200) systemd 230 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
07.09.17 15:12:31 (+0200) Detected virtualization docker.
07.09.17 15:12:31 (+0200) Detected architecture arm.
07.09.17 15:12:31 (+0200) Set hostname to <d367deb>.
07.09.17 15:12:31 (+0200) Failed to install release agent, ignoring: No such file or directory

#3

@Tristan107, you can ignore this message, it doesn’t affect your code in any way (ref https://docs.resin.io/runtime/runtime/#failed-to-install-release-agent). We no longer mount /sys/fs/cgroup on Debian Stretch so you see this message again,


#4

In my code and conf, I try to eliminate warnings each time it’s possible though, to make sure real warnings are not ignored, and to make sure false warnings don’t get undesserved attention and stand in the way of a problem resolution.

The link you are quoting also says : “This is a known issue (…) It was fixed (…) we recommend moving to a newer image”.

Is there any reason you don’t mount “/sys/fs/cgroup” in the Stretch image ?


#5

I have put this issue in to the prioritisation team. It looks to me as though it’s a line that got missed when creating a dockerfile for docker/systemd dependancy hell on Stretch (compare the last three lines of stretch and previous), but there may be something deeper going on.


#7

@Tristan107, mounting /sys/fs/cgroup will make systemd unable to start, it happens on newer versions of systemd so we no longer mount it on later version of systemd (Debian Stretch, Fedora 25)


#8

Yes, I’ve noticed this too. So, what is the alert message complaining about if it’s not the “/sys/fs/cgroup” mount ?


#9

@Tristan107, you will see something like this

Cannot determine cgroup we are running in: No medium found
Failed to allocate manager object: No medium found
[!!!!!!] Failed to allocate manager object, freezing.
Freezing execution.

if /sys/fs/crgoup is mounted, it’s related to these issues https://github.com/systemd/systemd/issues/6477, https://github.com/systemd/systemd/issues/6477. So for now, we won’t mount it in the base images and you can just ignore the “failed to install release agent” warning.


Can't find crontab or systemctl in Beaglebone debian image, what am I doing wrong?
#10

I am seeing this same issue in resin/beaglebone-black-node-node:slim based images.


#11

@team members with access to a beaglebone-black, could someone volunteer to attempt replication on this bug report?