Static IP Configuration Prevents LTE USB Modem from Enumerating


#1

We are using the DBUS interface from a script within our application container (running on a Raspberry Pi 3) to create a static, wired network connection on the host OS. Once we do this (successfully), our LTE USB modem (a U620L) fails to enumerate on eth1 (as it usually does in the absence of a static config). Do we need to add an explicit configuration to the host OS for the modem as well? Or maybe we are missing something else.


#3

@thisisbrians what do you mean that it fails to enumerate? Does the interface eth1 disappear completely? Are you constraining your static configuration to be applied only on eth0?


#4

It does not disappear entirely, but fails to show an IP address. Here’s the relevant section of the output from ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:2b:ad:58
          inet addr:10.168.2.123  Bcast:10.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe2b:ad58/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3284 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2578 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:718264 (701.4 KiB)  TX bytes:358542 (350.1 KiB)

eth1      Link encap:Ethernet  HWaddr 00:15:ff:05:64:00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:142 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13956 (13.6 KiB)  TX bytes:0 (0.0 B)

Currently we are not restricting the wired configuration to eth0.

Here is what our connection file comes out as:

[connection]
id=MyConnectionExample
uuid=748d3ae3-42d0-4d16-9be6-1b70621fa3ca
type=ethernet
permissions=
 
[ethernet]
mac-address-blacklist=
 
[ipv4]
address1=10.168.2.123/24,10.168.2.1
dns=8.8.8.8;
dns-search=
method=manual
 
[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

#5

I think the problem is that you’re not restricting your connection to the specific ethernet device. NetworkManager will only autogenerate a connection profile for an ethernet device if there is no other connection profile that applies to it. Since your connection profile applies to all ethernet devices it prevents eth1 from getting a connection. To fix this you’ll have to either constraint your static network connection to the specific adapter or add an explicit connection profile for your LTE USB modem.


#6

I restricted the wired static connection to eth0 and everything is working wonderfully now. My next step is to figure out how to selectively disable outbound (WAN) traffic from going through the wired connection (hopefully by preventing a default route from getting created on that interface). I can start a new thread if that becomes involved…


#7

@thisisbrians that’s great to hear. I can save you the trouble of searching for the default route. You just add never-default=true under the [ipv4] block


#8

Thank you, Petros! That did it :slight_smile: