RPi3 Wireless Access Point Security WPA2

access-point
wifi

#1

I’ve setup my Pi 3B+ as an access point following Resin’s instructions.
It works.
Yay!

But the Wifi Security is WPA. How do I use WPA2 instead? I’ve gone through the Network Manager documentation but have not been successful in working out what settings to use.

Thanks in advance for your help.


#4

Hi, NetworkManager manages that, and from the configuration file’s point of view regular WPA and WPA2 Personal are the same, as much as I know. That is if all you have is an SSID and a password, the configuration is the same. Have you tried that and didn’t work, or you have to connect to the network differently (e.g. if you need to use WPA2 Enterprise, which would be different).


#5

Using the configuration described in your docs here, a wifi hotspot is created that uses WPA and results in a warning being shown to users that join using iOS.

‘WPA is not considered secure. Configure your router to use WPA2 Personal (AES) security type for this network’

I’d like to know how to set up the hotspot to use WPA2 Personal AES instead. I don’t need WPA2 Enterprise.


#6

What happens if you use proto=RSN, and possibly other similar settings from this thread https://www.raspberrypi.org/forums/viewtopic.php?t=50312