RPi3 Wireless Access Point & Bridge Setup


#1

Hi, I’ve been following the steps here to set up my Pi with a WiFi hotspot on wlan0, and then bridging through to the internet on eth0.
I created the new file called resin-hotspot in /boot/system-connections. When I ssh onto the device and run nmcli, nmcli c and nmcli d I get the output below.

root@300f156:~# nmcli c
NAME                UUID                                  TYPE             DEVICE
Wired connection 1  f05c7ae5-67ba-3599-959f-b85f0ec9d49b  802-3-ethernet   eth0 
resin-hotspot       36060c57-aebd-4ccf-aba4-ef75121b5f77  802-11-wireless  --   
resin-wifi-01       a58e405d-fdc2-3649-9339-5bbaea740c76  802-11-wireless  -- 

When I run ifconfig or iwconfig, it does not list wlan0.

From the forum post, I understand the next thing I need to do is

Just drop the below example configuration into a file inside the /boot/system-connections >directory on the SD card and name it resin-hotspot, next use the Network Manager DBUS API28 to >enable the connection called resin-hotspot.

However, I’m stuck at this - I’m totally new to this so probably misunderstanding, but I don’t have Python available on the resinos for example, or apt-get to install it. I modified the dockerfile for the container to install the python-networkmanager library, but when I import it it gives an error.

Can anyone help me understand how to proceed please?

(To give the use-case, before discovering resin I had a few Pis set up with an access point on a usb WiFi bridging through on eth0. Then I have a Python script getting data from some devices on this WiFi/private network and sending it up over the internet to a database. I’m now looking to switch this setup over to resin and scale it up to a more devices)


#2

Ah, I changed to a different Pi and it works now, perhaps there was a hardware error.
To bring up the connection in the first place I connected to the host os and ran the command
nmcli connection up resin-hotspot --ask
However, I then modified the resin-hotspot file within /boot/system-connections and set auto-connect = True. Now the access point is visible as soon as the device starts up. Fantastic!