Resin UTC Date in the past


#1

For some reason we have a resin device that is always reverting to 2017-10-02 UTC today when it should be 2017-10-07.
It’s messing up a lot of audit calculations. I manually set the date a couple of times today via date -s - which temporarily worked then i check back a few hours later to find it has reverted. We have several devices in the field and this is the only one that has done that. Thanks in advance.


#3

Hi, thank you for your report.

Have a few questions:
1 - what device type is this?
2 - What resinOS version is it running?
3 - Is this device deployed in the same local network as the others you are mentioning?
4- Are there any restrictions in that network? Please note the network requirements here: https://docs.resin.io/deployment/network/2.0.0/#network-requirements

Thank you


#4

Device Type Raspberry Pi 3
Resin OS 2.3.0+rev1 (prod)
Different Network
ntp http https open
–ntp
0.resinio.pool.ntp.org [198.58.110.84] 123 (ntp) open
–http
[216.58.217.196] 80 (http) open
–https
[216.58.217.196] 443 (https) open

Sorry for abbreviated commands above the editor would only allow 2 links in this text box
Thanks


#5

–dns
www.google.com [172.217.4.132] 53 (domain) open


#6

root@702c5be-702c5be:/usr# nc -zvu time1.google.com 123
time1.google.com [216.239.35.0] 123 (ntp) open
root@702c5be-702c5be:/usr# ntpdate time1.google.com
8 Oct 01:46:52 ntpdate[2522]: no server suitable for synchronization found
root@702c5be-702c5be:/usr# ^C
root@702c5be-702c5be:/usr# ntpdate -vd
8 Oct 01:49:06 ntpdate[2549]: ntpdate 4.2.6p5@1.2349-o Fri Jul 22 17:59:27 UTC 2016 (1)
8 Oct 01:49:06 ntpdate[2549]: no servers can be used, exiting


#7

Hey @coffmantech, can you please try to synchronize to this server 0.resinio.pool.ntp.org?
It’s the default server that resinOS uses.


#8

same results no matter which ntp server
—netcat shows udp port 123 open to resin ntp…
root@702c5be-702c5be:/usr# nc -zvu 0.resinio.pool.ntp.org 123
DNS fwd/rev mismatch: 0.resinio.pool.ntp.org != 4.144.155.104.bc.googleusercontent.com
DNS fwd/rev mismatch: 0.resinio.pool.ntp.org != srcf-ntp.stanford.edu
DNS fwd/rev mismatch: 0.resinio.pool.ntp.org != time-a.timefreq.bldrdoc.gov
DNS fwd/rev mismatch: 0.resinio.pool.ntp.org != clock.xmission.com
0.resinio.pool.ntp.org [104.155.144.4] 123 (ntp) open

– ntp fail
root@702c5be-702c5be:/usr# ntpdate 0.resinio.pool.ntp.org
9 Oct 17:39:11 ntpdate[1792]: no server suitable for synchronization found


#9

result of dbus ntp sync inquiry

root@702c5be-702c5be:/usr# DBUS_SYSTEM_BUS_ADDRESS=unix:path=/host/run/dbus/system_bus_socket \

dbus-send
–system
–print-reply
–reply-timeout=2000
–type=method_call
–dest=org.freedesktop.timedate1
/org/freedesktop/timedate1
org.freedesktop.DBus.Properties.GetAll
string:"org.freedesktop.timedate1"
method return sender=:1.15 -> dest=:1.14 reply_serial=2
array [
dict entry(
string "Timezone"
variant string “”
)
dict entry(
string "LocalRTC"
variant boolean false
)
dict entry(
string "CanNTP"
variant boolean true
)
dict entry(
string "NTP"
variant boolean true
)
dict entry(
string "NTPSynchronized"
variant boolean false
)
dict entry(
string "TimeUSec"
variant uint64 1507571195682940
)
dict entry(
string "RTCTimeUSec"
variant uint64 0
)
]


#10

Hey @coffmantech, could you post the log output of the time sync daemon? The following command should do the trick:

$ journalctl -u systemd-timesyncd -e

#11

root@702c5be-702c5be:/usr# journalctl -u systemd-timesyncd -e
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
– Logs begin at Mon 2017-10-02 19:27:33 UTC, end at Mon 2017-10-09 18:43:09 UTC. –


#12

nothing in syslog generated from the above command - if there was any expected :slight_smile:


#13

Hey @coffmantech, could you restart the timesync daemon to make it emit some logs with

$ systemctl restart systemd-timesyncd

Then please post the log output of

$ journalctl -u systemd-timesyncd -e

and

$ systemctl status systemd-timesyncd


#15

root@702c5be-702c5be:/usr# journalctl -u systemd-timesyncd -e
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
– Logs begin at Mon 2017-10-02 19:27:43 UTC, end at Thu 2017-10-12 14:12:06 UTC. –
Oct 12 14:12:06 702c5be-702c5be systemd[1]: Started Network Time Synchronization.
root@702c5be-702c5be:/usr# systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled)
Active: inactive (dead)
Docs: man:systemd-timesyncd.service(8)


#16

^ looks like that may have something to do with it


#17

@coffmantech could you try running the ntpdate -dv 0.resinio.pool.ntp.org so we can get a bit more debug information to work with? Thanks.


#18

root@24b17d8-24b17d8:/usr# ntpdate -dv 0.resinio.pool.ntp.org
13 Oct 19:04:24 ntpdate[3219]: ntpdate 4.2.6p5@1.2349-o Fri Jul 22 17:59:27 UTC 2016 (1)
transmit(69.61.82.106)
transmit(45.33.84.208)
transmit(208.75.89.4)
transmit(107.155.72.138)
transmit(69.61.82.106)
transmit(45.33.84.208)
transmit(208.75.89.4)
transmit(107.155.72.138)
transmit(69.61.82.106)
transmit(45.33.84.208)
transmit(208.75.89.4)
transmit(107.155.72.138)
transmit(69.61.82.106)
transmit(45.33.84.208)
transmit(208.75.89.4)
transmit(107.155.72.138)
transmit(69.61.82.106)
transmit(45.33.84.208)
transmit(208.75.89.4)
transmit(107.155.72.138)
69.61.82.106: Server dropped: no data
45.33.84.208: Server dropped: no data
208.75.89.4: Server dropped: no data
107.155.72.138: Server dropped: no data
server 69.61.82.106, port 123
stratum 0, precision 0, leap 00, trust 000
refid [69.61.82.106], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
originate timestamp: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
transmit timestamp: dd8b8cbe.bbb114b1 Fri, Oct 13 2017 19:04:30.733
filter delay: 0.00000 0.00000 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
filter offset: 0.000000 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

server 45.33.84.208, port 123
stratum 0, precision 0, leap 00, trust 000
refid [45.33.84.208], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
originate timestamp: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
transmit timestamp: dd8b8cbe.eee39066 Fri, Oct 13 2017 19:04:30.933
filter delay: 0.00000 0.00000 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
filter offset: 0.000000 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

server 208.75.89.4, port 123
stratum 0, precision 0, leap 00, trust 000
refid [208.75.89.4], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
originate timestamp: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
transmit timestamp: dd8b8cbf.22172c75 Fri, Oct 13 2017 19:04:31.133
filter delay: 0.00000 0.00000 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
filter offset: 0.000000 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

server 107.155.72.138, port 123
stratum 0, precision 0, leap 00, trust 000
refid [107.155.72.138], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
originate timestamp: 00000000.00000000 Thu, Feb 7 2036 6:28:16.000
transmit timestamp: dd8b8cbf.554a9a31 Fri, Oct 13 2017 19:04:31.333
filter delay: 0.00000 0.00000 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
filter offset: 0.000000 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

13 Oct 19:04:33 ntpdate[3219]: no server suitable for synchronization found


#20

Hello,
is there a chance that there’s something in your network blocking it?
Is it possible to try from a different network or try to disable any firewalls at least for a while in order to check if your device manages to sync?


#21

…it was apparently. The odd thing is that netcat showed an unblocked connection over udp 123 to the resin timeserver which doesn’t lend confidence to my troubleshooting ability :slight_smile:


#22

I’m glad that you found the issue!

Best,
ilias