Resin proxy times out socket after 2 minutes

support
raspberrypi3

#1

Hello! We’re building a raspberry pi based video transmission system using webrtc for the media and websockets for the signalling. The goal is to have a pi on a 4g network being capable to transmit video to a peer that connects to its public, proxied address provided by resin.

We’re able to get it running… for up to 2 minutes at a time. The socket gets closed (because there is no data being transmitted over the signaling channel) and the video transmission gets killed. Prior to migrating the project to resin, we used another proxying service (ngrok), and we faced a similar issue. It was resolved by switching from http to tcp proxying - is there any configuration I can touch to enable this with resin? Or some alternative way I can make sure that the socket doesn’t get timed out?


#3

hello,

I’m not aware of a specific configuration right now, but would you like to take a look here?

Best,
ilias


#4

Hi ilias, thanks for the response.

I’m not entierly sure I understand how this applies - this is for node apps, right? We have a service written in c running on the Pi. I was hoping that maybe it’s a limitation somewhere in resin that we can modify with a setting.


#5

Hi @sasha, I’m not aware of any configuration for timeouts in our VPN/proxy code, but I’ve pinged the maintainer of that part of our stack who will probably have a better answer


#7

Thanks @pcarranzav! For reference, with ngrok the difference was using a TCP tunnel instead of a HTTP tunnel.