Proxy-Settings for Static IP Configuration


#1

Hi,

I have a customer that needs a static ip set on a resin.io powered device. I know that this is really straightforward and also very well documented in the following blog post. https://resin.io/blog/how-to-configure-a-static-ip-address-with-resin-io/ - but the customer also provided me a proxy setting but I have no clue how to set proxy settings within the config.json. Is this possible? I am looking for some sample config.json for the proxy part.

Thanks,

Simon


Setup resin.io behind corporate proxy/firewall
#2

As far as I know, proxy is not possible at the moment. I’m guessing (and this is just a guess), that it should be somewhat better in resinOS 2.x in the future (where NetworkManager is used), but it will need some more tools added to the host OS for that. It’s something we are working on, but not available yet.

Generally there’s more info about networking requirements and settings in the docs at https://docs.resin.io/deployment/network/

Is there any way, that this customer can work without the proxy for these devices?


#3

Any update on this - running devices behind a web proxy ?


#4

@galo there is indeed. It’s now possible to run resin devices behind a SOCKS proxy. @imrehg or @zwalchuk do you have a quick set of instructions for this, since it hasn’t made it into the public docs yet.


#5

Thanks! If you have some instructions that would be awsome


#6

Yep, here are the basics:

To enable, a redsocks.conf file should be added to the /system-proxy/ folder on the resin-boot partition, specifying the needed proxy configuration and ensuring that:

  • daemon = off is set, so that redsocks doesn’t fork.
  • local_port = 12345 is set, so that the iptables rules and redsocks’ port match.

Additionally, a /mnt/boot/system-proxy/no_proxy file can be added with a newline-separated list of IPs or subnets to not route through the proxy.


Resin on VirtualBox
#7

Thanks


#8

Can the resin img cp command be used to copy the file into an image? I have copied other files but for this one I’m seeing No such file or directory - seems like the /system-proxy folder may not exist, but I’m not sure.

I’m able to copy files to /splash just fine, so that’s why I’m confused.

Thanks,

-James


#9

I was able to just mount the .img file directly and copy the file over, so all good.