Problem Raspberry Pi 2 Resin OS v.2.9.6 and PI4J


#1

Good morning,

I have a problem with the Resin OS v2.9.6. I put a new Raspberry 2 in my current application. In the moment in that the software start-up, I obtain this error and the program stop:

Unable to determine hardware version. I see: Hardware : BCM2835, expecting BCM2708 or BCM2709.
If this is a genuine Raspberry Pi then please report this to projects@drogon.net. If this is not a Raspberry Pi then you are on your own as wiringPi is designed to support the Raspberry Pi ONLY.

My software use Java 8 and pi4j Version 1.1. I have many nodes in production with the same software version and them works fine, but these use the Resin OS Version 2.2.0.

Can someone help me?

Thank you.


#4

@leandro have you seen this issue on the Pi4J repo?