Preloaded image takes long time to boot


#1

When I boot a preloaded image on my Pi3 for the first times it takes a long time to register and before my app shows up on the screen.
I was looking at the logs and noticed that the app is installed multiple times, killed etc.
Does this look it is suppose to? I was surprised that the first boot is so slow when all the application code is inlined in the image already.

(I’m running Resinos 2.0+rev2 and an app based on the resin-electronjs sample.

06.04.17 13:02:48 (+0000) Rebooting
06.04.17 13:02:49 (+0000) Installing application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:02:49 (+0000) Installed application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:02:49 (+0000) Starting application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:17 (+0000) Installing application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:18 (+0000) Installed application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:18 (+0000) Starting application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:19 (+0000) Started application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:19 (+0000) Systemd init system enabled.
06.04.17 13:05:19 (+0000) systemd 215 running in system mode. (+PAM +AUDIT +SELI
NUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ -SECCOMP -APPARMOR)
06.04.17 13:05:19 (+0000) Detected virtualization 'other'.
06.04.17 13:05:19 (+0000) Detected architecture 'arm'.
06.04.17 13:05:19 (+0000) Set hostname to <aaaaaaa-aaaaaaaa>.
06.04.17 13:05:21 (+0000) Updating application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:21 (+0000) Killing application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:26 (+0000) Application exited 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:27 (+0000) Killed application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:27 (+0000) Installing application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:27 (+0000) Installed application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:27 (+0000) Starting application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:28 (+0000) Started application 'registry.resin.io/xx/1234567890123456789012345678901234567890'
06.04.17 13:05:28 (+0000) Systemd init system enabled.

#2

Hi, there was an issue recently with the resin-supervisor that does the app install and load, which was uncovered through doing a bunch of different preloading. Not :100:% sure that it’s the same thing, but it feels related, and if it is, then there’s a fix in testing right now. Will keep you posted, and thanks for reporting this!