Odroid XU4 i2c fan issues


#1

Hello :slight_smile:

I am trying to get my fan to work on my Odroid XU4, I’m using the 2.13.6-rev1 and the resin/odroid-xu4-ubuntu-buildpack-deps:latest base image and when I run i2cset -y 1 0x60 0x05 0x00 I get the error Error: Could not open file /dev/i2c-1' or /dev/i2c/1': No such file or directory. This command works on the Hardkernel provided ubuntu image after this install proceses https://wiki.odroid.com/accessory/add-on_boards/xu4_cloudshell2/easy_install. Any tips or pointers would be greatly appreciated!

I’m also having a hard time getting my LCDs (320x240 TFT LCD using SPI) to work, but that is a whole other issue. The fan is much more pressing because we are having thermal issues.

Thanks in advance!!!


#4

We tried using the odroid-xu4-node base image because it includes udev (we thought that may have been the cause) but got the same error. We are ready to deploy around 20 devices but are unable to until this fan (thermal problems) issue is solved.

@pcarranzav


#9

Hey @Jacob would you mind sharing your Dockerfile with us so we can take a closer look?


#15

Thanks for getting back to me :slight_smile: @_Page

FROM resin/odroid-xu4-node

RUN apt-get update && apt-get install -yq \
    ntfs-3g parted && \
    apt-get clean && rm -rf /var/lib/apt/lists/*

# Defines our working directory in container
WORKDIR /usr/src/app

# Copies the package.json first for better cache on later pushes
COPY package.json package.json

# This install npm dependencies on the resin.io build server,
# making sure to clean up the artifacts it creates in order to reduce the image size.
RUN JOBS=MAX npm install --production --unsafe-perm && npm cache clean --force && rm -rf /tmp/*

# This will copy all files in our root to the working  directory in the container
COPY . ./

RUN chmod 700 ./formatdrives.sh

# Enable systemd init system in container
ENV INITSYSTEM on

# server.js will run when container starts up on the device
CMD ["npm", "start"]

#22

@Jacob I’ve been able to reproduce that i2c-1 does not exist on either the host os or in the container although i2c-2 and i2c-4 do exist. I’ve forwarded this onto our device team to look deeper into it


#25

@_Page Thanks for your quick response!

Any estimate on when the device team will be looking at it?

Thanks!