Network not setting according to the resin-sample config


#1

For some reason when I reboot the ip is set according to dhcp and NOT the resin-sample file. The resin-sample worked until the last update. Any thoughts?

For sanity check, here is my resin-sample and Linux versions

root@hassio:~# uname -a
Linux hassio 4.4.50 #2 SMP Sun Sep 17 19:04:03 UTC 2017 armv7l armv7l armv7l GNU/Linux
root@hassio:~# uname -r
4.4.50
root@hassio:~# cat /proc/version
Linux version 4.4.50 (builder@4964762b971a) (gcc version 6.2.0 (GCC) ) #2 SMP Sun Sep 17 19:04:03 UTC 2017
root@hassio:~# cat /etc/issue
Resin OS 2.0.9 \n \l

root@hassio:~# cat /mnt/boot/system-connections/resin-sample
[connection]
id=HomeAssistant
type=ethernet
interface-name=eth0
permissions=
secondaries=

[ethernet]
mac-address-blacklist=

[ipv4]
address1=192.168.1.160/24,192.168.1.254
dns=8.8.8.8;8.8.4.4;
dns-search=
method=manual

ignore-auto-routes=true
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

#3

Just to clarify the report: what you are expecting is that resin-sample be ignored, right?


#4

I edited my post to make it clearer. Sorry. :blush:

I expect the resin-sample to enforced.
It worked until I ran an update. I wondering if something got loaded down that would override the resin-sample?
The resin-snippet is what I want my settings to be.

One other point of information, this is a hassio build, and it was upgraded with the hassio upgrade option. I wonder if it put something down that is overriding resin-sample?

I guess bottom line, what if any can override the resin-sample?


#5

So, before the update, the network was configured as specified in resin-snippet. But since the update, resin-snippet is ignored and resin-sample is used. Am I right?


#6

It would help as well to mention what versions you updated from and to.


#7

Can’t remember what it was before 1.3 or something sorry.
What it is now:
Host system
Hostname hassio
System Resin OS 2.3.0+rev1

Sorry, not understanding the “resin-snippet”. I am running headless on Raspberry PI 3. I wanted a static IP since I am running Home Assistant. So I created a resin-sample according this https://docs.resin.io/reference/resinOS/network/2.x/#setting-a-static-ip
That all worked. I have not changed the file since the update. Now when the resin os boots it gets an IP from the dhcp and not set it static according to the resin-sample.

Any logs that would help?

@agherzan thanks for your time.


#8

I understood now the problem. Network manager logs would help. You can get them by ssh-ing on the device and running journalctl - u NetworkManager.


#9

Here it the current one. If I need to reboot and capture a new one let me know.

-- Logs begin at Mon 2018-07-02 08:53:52 UTC, end at Mon 2018-07-02 12:20:21 UTC. --
Jul 02 08:54:11 hassio NetworkManager[695]: <info>  [1530521651.7907] device (wlan0): set-hw-addr: set MAC address to BE:3C:58:F2:5E:B9 (scanning)
Jul 02 08:54:11 hassio NetworkManager[695]: <info>  [1530521651.7971] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 08:54:11 hassio NetworkManager[695]: <info>  [1530521651.8020] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 08:59:27 hassio NetworkManager[695]: <info>  [1530521967.8048] device (wlan0): set-hw-addr: set MAC address to 4A:A1:4F:72:6A:3B (scanning)
Jul 02 08:59:27 hassio NetworkManager[695]: <info>  [1530521967.8113] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 08:59:27 hassio NetworkManager[695]: <info>  [1530521967.8160] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:04:43 hassio NetworkManager[695]: <info>  [1530522283.8413] device (wlan0): set-hw-addr: set MAC address to 56:E8:80:00:65:83 (scanning)
Jul 02 09:04:43 hassio NetworkManager[695]: <info>  [1530522283.8489] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:04:43 hassio NetworkManager[695]: <info>  [1530522283.8523] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:09:59 hassio NetworkManager[695]: <info>  [1530522599.8072] device (wlan0): set-hw-addr: set MAC address to 52:E9:4C:C7:97:56 (scanning)
Jul 02 09:09:59 hassio NetworkManager[695]: <info>  [1530522599.8134] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:09:59 hassio NetworkManager[695]: <info>  [1530522599.8192] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:15:15 hassio NetworkManager[695]: <info>  [1530522915.8105] device (wlan0): set-hw-addr: set MAC address to 1E:88:50:79:23:E8 (scanning)
Jul 02 09:15:15 hassio NetworkManager[695]: <info>  [1530522915.8168] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:15:15 hassio NetworkManager[695]: <info>  [1530522915.8246] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:20:31 hassio NetworkManager[695]: <info>  [1530523231.7899] device (wlan0): set-hw-addr: set MAC address to 2A:CE:AD:CE:F0:3E (scanning)
Jul 02 09:20:31 hassio NetworkManager[695]: <info>  [1530523231.7967] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:20:31 hassio NetworkManager[695]: <info>  [1530523231.8005] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:25:47 hassio NetworkManager[695]: <info>  [1530523547.8406] device (wlan0): set-hw-addr: set MAC address to CA:83:1E:7E:B2:1E (scanning)
Jul 02 09:25:47 hassio NetworkManager[695]: <info>  [1530523547.8494] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:25:47 hassio NetworkManager[695]: <info>  [1530523547.8536] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:31:03 hassio NetworkManager[695]: <info>  [1530523863.7907] device (wlan0): set-hw-addr: set MAC address to D6:6A:38:D4:D9:97 (scanning)
Jul 02 09:31:03 hassio NetworkManager[695]: <info>  [1530523863.7979] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:31:03 hassio NetworkManager[695]: <info>  [1530523863.8015] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:36:19 hassio NetworkManager[695]: <info>  [1530524179.8202] device (wlan0): set-hw-addr: set MAC address to 96:C7:EA:DB:35:E7 (scanning)
Jul 02 09:36:19 hassio NetworkManager[695]: <info>  [1530524179.8268] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:36:19 hassio NetworkManager[695]: <info>  [1530524179.8306] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:41:35 hassio NetworkManager[695]: <info>  [1530524495.8510] device (wlan0): set-hw-addr: set MAC address to 56:42:2B:B3:36:D9 (scanning)
Jul 02 09:41:35 hassio NetworkManager[695]: <info>  [1530524495.8545] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:41:35 hassio NetworkManager[695]: <info>  [1530524495.8594] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:46:51 hassio NetworkManager[695]: <info>  [1530524811.7910] device (wlan0): set-hw-addr: set MAC address to 26:02:EB:9C:E0:4F (scanning)
Jul 02 09:46:51 hassio NetworkManager[695]: <info>  [1530524811.7976] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:46:51 hassio NetworkManager[695]: <info>  [1530524811.8009] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:52:07 hassio NetworkManager[695]: <info>  [1530525127.7911] device (wlan0): set-hw-addr: set MAC address to FA:67:0C:18:41:01 (scanning)
Jul 02 09:52:07 hassio NetworkManager[695]: <info>  [1530525127.8023] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:52:07 hassio NetworkManager[695]: <info>  [1530525127.8062] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 09:57:23 hassio NetworkManager[695]: <info>  [1530525443.7910] device (wlan0): set-hw-addr: set MAC address to C6:B9:FA:6A:80:E3 (scanning)
Jul 02 09:57:23 hassio NetworkManager[695]: <info>  [1530525443.8044] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 09:57:23 hassio NetworkManager[695]: <info>  [1530525443.8051] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:02:39 hassio NetworkManager[695]: <info>  [1530525759.7910] device (wlan0): set-hw-addr: set MAC address to CE:9B:E3:14:30:EF (scanning)
Jul 02 10:02:39 hassio NetworkManager[695]: <info>  [1530525759.8003] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:02:39 hassio NetworkManager[695]: <info>  [1530525759.8036] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:07:55 hassio NetworkManager[695]: <info>  [1530526075.7912] device (wlan0): set-hw-addr: set MAC address to 56:F4:F9:2C:16:22 (scanning)
Jul 02 10:07:55 hassio NetworkManager[695]: <info>  [1530526075.7983] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:07:55 hassio NetworkManager[695]: <info>  [1530526075.8019] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:13:11 hassio NetworkManager[695]: <info>  [1530526391.8506] device (wlan0): set-hw-addr: set MAC address to A6:BF:ED:28:8D:79 (scanning)
Jul 02 10:13:11 hassio NetworkManager[695]: <info>  [1530526391.8574] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:13:11 hassio NetworkManager[695]: <info>  [1530526391.8611] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:18:27 hassio NetworkManager[695]: <info>  [1530526707.8501] device (wlan0): set-hw-addr: set MAC address to 9E:27:56:4D:FD:06 (scanning)
Jul 02 10:18:27 hassio NetworkManager[695]: <info>  [1530526707.8595] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:18:27 hassio NetworkManager[695]: <info>  [1530526707.8618] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:23:43 hassio NetworkManager[695]: <info>  [1530527023.7912] device (wlan0): set-hw-addr: set MAC address to 8E:44:07:8F:37:20 (scanning)
Jul 02 10:23:43 hassio NetworkManager[695]: <info>  [1530527023.8018] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:23:43 hassio NetworkManager[695]: <info>  [1530527023.8062] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:28:59 hassio NetworkManager[695]: <info>  [1530527339.7913] device (wlan0): set-hw-addr: set MAC address to BA:67:7D:34:4D:91 (scanning)
Jul 02 10:28:59 hassio NetworkManager[695]: <info>  [1530527339.7982] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:28:59 hassio NetworkManager[695]: <info>  [1530527339.8038] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:34:15 hassio NetworkManager[695]: <info>  [1530527655.7911] device (wlan0): set-hw-addr: set MAC address to 72:C5:56:72:F6:AF (scanning)
Jul 02 10:34:15 hassio NetworkManager[695]: <info>  [1530527655.7980] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:34:15 hassio NetworkManager[695]: <info>  [1530527655.8039] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:39:31 hassio NetworkManager[695]: <info>  [1530527971.8020] device (wlan0): set-hw-addr: set MAC address to 66:58:1F:D7:DB:08 (scanning)
Jul 02 10:39:31 hassio NetworkManager[695]: <info>  [1530527971.8138] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:39:31 hassio NetworkManager[695]: <info>  [1530527971.8165] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:44:47 hassio NetworkManager[695]: <info>  [1530528287.8018] device (wlan0): set-hw-addr: set MAC address to F6:1E:20:D8:44:0F (scanning)
Jul 02 10:44:47 hassio NetworkManager[695]: <info>  [1530528287.8059] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:44:47 hassio NetworkManager[695]: <info>  [1530528287.8582] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:50:03 hassio NetworkManager[695]: <info>  [1530528603.8514] device (wlan0): set-hw-addr: set MAC address to CA:9A:33:9A:6A:F5 (scanning)
Jul 02 10:50:03 hassio NetworkManager[695]: <info>  [1530528603.8577] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:50:03 hassio NetworkManager[695]: <info>  [1530528603.8610] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 10:55:19 hassio NetworkManager[695]: <info>  [1530528919.8015] device (wlan0): set-hw-addr: set MAC address to 82:37:6F:9A:17:54 (scanning)
Jul 02 10:55:19 hassio NetworkManager[695]: <info>  [1530528919.8112] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 10:55:19 hassio NetworkManager[695]: <info>  [1530528919.8145] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:00:35 hassio NetworkManager[695]: <info>  [1530529235.8201] device (wlan0): set-hw-addr: set MAC address to A6:13:FF:00:94:48 (scanning)
Jul 02 11:00:35 hassio NetworkManager[695]: <info>  [1530529235.8266] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:00:35 hassio NetworkManager[695]: <info>  [1530529235.8302] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:05:51 hassio NetworkManager[695]: <info>  [1530529551.8406] device (wlan0): set-hw-addr: set MAC address to EA:9B:35:2A:94:15 (scanning)
Jul 02 11:05:51 hassio NetworkManager[695]: <info>  [1530529551.8442] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:05:51 hassio NetworkManager[695]: <info>  [1530529551.8502] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:11:07 hassio NetworkManager[695]: <info>  [1530529867.8414] device (wlan0): set-hw-addr: set MAC address to 92:3A:1A:90:24:12 (scanning)
Jul 02 11:11:07 hassio NetworkManager[695]: <info>  [1530529867.8477] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:11:07 hassio NetworkManager[695]: <info>  [1530529867.8505] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:16:23 hassio NetworkManager[695]: <info>  [1530530183.7896] device (wlan0): set-hw-addr: set MAC address to 02:B3:FD:B5:7D:D3 (scanning)
Jul 02 11:16:23 hassio NetworkManager[695]: <info>  [1530530183.7963] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:16:23 hassio NetworkManager[695]: <info>  [1530530183.7996] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:21:39 hassio NetworkManager[695]: <info>  [1530530499.8014] device (wlan0): set-hw-addr: set MAC address to 8E:23:EF:7C:49:28 (scanning)
Jul 02 11:21:39 hassio NetworkManager[695]: <info>  [1530530499.8077] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:21:39 hassio NetworkManager[695]: <info>  [1530530499.8112] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:26:55 hassio NetworkManager[695]: <info>  [1530530815.8413] device (wlan0): set-hw-addr: set MAC address to 8A:A4:63:C9:63:D1 (scanning)
Jul 02 11:26:55 hassio NetworkManager[695]: <info>  [1530530815.8500] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:26:55 hassio NetworkManager[695]: <info>  [1530530815.8538] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:32:11 hassio NetworkManager[695]: <info>  [1530531131.8014] device (wlan0): set-hw-addr: set MAC address to 96:30:D5:73:D0:B5 (scanning)
Jul 02 11:32:11 hassio NetworkManager[695]: <info>  [1530531131.8077] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:32:11 hassio NetworkManager[695]: <info>  [1530531131.8115] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:37:27 hassio NetworkManager[695]: <info>  [1530531447.8006] device (wlan0): set-hw-addr: set MAC address to EA:0E:E0:3F:64:9F (scanning)
Jul 02 11:37:27 hassio NetworkManager[695]: <info>  [1530531447.8046] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:37:27 hassio NetworkManager[695]: <info>  [1530531447.8082] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:42:43 hassio NetworkManager[695]: <info>  [1530531763.8113] device (wlan0): set-hw-addr: set MAC address to F2:00:67:BE:F6:79 (scanning)
Jul 02 11:42:43 hassio NetworkManager[695]: <info>  [1530531763.8177] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:42:43 hassio NetworkManager[695]: <info>  [1530531763.8214] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:47:59 hassio NetworkManager[695]: <info>  [1530532079.8115] device (wlan0): set-hw-addr: set MAC address to 8E:6A:0C:5D:D5:96 (scanning)
Jul 02 11:47:59 hassio NetworkManager[695]: <info>  [1530532079.8177] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:47:59 hassio NetworkManager[695]: <info>  [1530532079.8199] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:53:15 hassio NetworkManager[695]: <info>  [1530532395.8300] device (wlan0): set-hw-addr: set MAC address to AA:DC:0F:EE:AB:B4 (scanning)
Jul 02 11:53:15 hassio NetworkManager[695]: <info>  [1530532395.8378] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:53:15 hassio NetworkManager[695]: <info>  [1530532395.8408] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 11:58:31 hassio NetworkManager[695]: <info>  [1530532711.8509] device (wlan0): set-hw-addr: set MAC address to E6:1F:2B:07:B4:07 (scanning)
Jul 02 11:58:31 hassio NetworkManager[695]: <info>  [1530532711.8571] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 11:58:31 hassio NetworkManager[695]: <info>  [1530532711.8605] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 12:03:47 hassio NetworkManager[695]: <info>  [1530533027.7901] device (wlan0): set-hw-addr: set MAC address to FA:1D:24:67:6F:B6 (scanning)
Jul 02 12:03:47 hassio NetworkManager[695]: <info>  [1530533027.7968] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 12:03:47 hassio NetworkManager[695]: <info>  [1530533027.8012] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 12:09:03 hassio NetworkManager[695]: <info>  [1530533343.8499] device (wlan0): set-hw-addr: set MAC address to 16:D7:83:2E:85:84 (scanning)
Jul 02 12:09:03 hassio NetworkManager[695]: <info>  [1530533343.8566] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 12:09:03 hassio NetworkManager[695]: <info>  [1530533343.8615] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 12:14:19 hassio NetworkManager[695]: <info>  [1530533659.7896] device (wlan0): set-hw-addr: set MAC address to 02:25:48:17:95:FD (scanning)
Jul 02 12:14:19 hassio NetworkManager[695]: <info>  [1530533659.8001] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 12:14:19 hassio NetworkManager[695]: <info>  [1530533659.8031] device (wlan0): supplicant interface state: disabled -> inactive
Jul 02 12:19:35 hassio NetworkManager[695]: <info>  [1530533975.8039] device (wlan0): set-hw-addr: set MAC address to 06:9F:1A:A6:B1:98 (scanning)
Jul 02 12:19:35 hassio NetworkManager[695]: <info>  [1530533975.8106] device (wlan0): supplicant interface state: inactive -> disabled
Jul 02 12:19:35 hassio NetworkManager[695]: <info>  [1530533975.8137] device (wlan0): supplicant interface state: disabled -> inactive

#10

One other note, I just ran ifconfig and it is showing the eth0: set back to 192.168.1.8 and not 192.168.1.160.
But right now I can communicate to it. Now I am confused.

root@hassio:/resin-data/homeassistant# ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:50:0B:3F:B3  
          inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::42:50ff:fe0b:3fb3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24212 errors:0 dropped:0 overruns:0 frame:0
          TX packets:104706 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1392872 (1.3 MiB)  TX bytes:10709676 (10.2 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:DE:A5:A0  
          inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::671a:c43a:2984:f22d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:839698 errors:0 dropped:0 overruns:0 frame:0
          TX packets:448525 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:218587019 (208.4 MiB)  TX bytes:65899019 (62.8 MiB)

hassio    Link encap:Ethernet  HWaddr 02:42:03:FD:3B:C4  
          inet addr:172.30.32.1  Bcast:0.0.0.0  Mask:255.255.254.0
          inet6 addr: fe80::42:3ff:fefd:3bc4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:257878 errors:0 dropped:0 overruns:0 frame:0
          TX packets:354758 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:24284386 (23.1 MiB)  TX bytes:100799073 (96.1 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:118011 errors:0 dropped:0 overruns:0 frame:0
          TX packets:118011 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:8381176 (7.9 MiB)  TX bytes:8381176 (7.9 MiB)

veth0a3dfd0 Link encap:Ethernet  HWaddr 8A:15:83:B2:E9:6B  
          inet6 addr: fe80::8815:83ff:feb2:e96b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:81871 errors:0 dropped:0 overruns:0 frame:0
          TX packets:161734 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8896195 (8.4 MiB)  TX bytes:15734610 (15.0 MiB)

veth18159cd Link encap:Ethernet  HWaddr E2:21:28:64:18:4E  
          inet6 addr: fe80::e021:28ff:fe64:184e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:84192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:7490061 (7.1 MiB)

veth745494a Link encap:Ethernet  HWaddr 4A:1D:03:63:83:C8  
          inet6 addr: fe80::481d:3ff:fe63:83c8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7332 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50147 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:817945 (798.7 KiB)  TX bytes:4289935 (4.0 MiB)

veth76e25a9 Link encap:Ethernet  HWaddr 4E:DD:7F:A1:E2:A3  
          inet6 addr: fe80::4cdd:7fff:fea1:e2a3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31025 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1577171 (1.5 MiB)  TX bytes:9768905 (9.3 MiB)

veth95393fe Link encap:Ethernet  HWaddr 7A:7A:6C:BD:40:9F  
          inet6 addr: fe80::787a:6cff:febd:409f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:476 errors:0 dropped:0 overruns:0 frame:0
          TX packets:83984 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:70776 (69.1 KiB)  TX bytes:7541707 (7.1 MiB)

vetha54c385 Link encap:Ethernet  HWaddr 7A:F1:B4:71:2C:6D  
          inet6 addr: fe80::78f1:b4ff:fe71:2c6d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4600 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47311 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:316265 (308.8 KiB)  TX bytes:4516679 (4.3 MiB)

vetha6c9a3d Link encap:Ethernet  HWaddr 3A:1D:ED:23:9B:0C  
          inet6 addr: fe80::381d:edff:fe23:9b0c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22618 errors:0 dropped:0 overruns:0 frame:0
          TX packets:103173 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2335805 (2.2 MiB)  TX bytes:17445350 (16.6 MiB)

vethbda93b7 Link encap:Ethernet  HWaddr DE:03:C0:B7:98:EC  
          inet6 addr: fe80::dc03:c0ff:feb7:98ec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83 errors:0 dropped:0 overruns:0 frame:0
          TX packets:84355 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7395 (7.2 KiB)  TX bytes:7585778 (7.2 MiB)

vethbffc936 Link encap:Ethernet  HWaddr 16:55:63:2A:D5:34  
          inet6 addr: fe80::1455:63ff:fe2a:d534/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9037 errors:0 dropped:0 overruns:0 frame:0
          TX packets:93682 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5571951 (5.3 MiB)  TX bytes:12524535 (11.9 MiB)

vethe992b07 Link encap:Ethernet  HWaddr B2:3D:8C:1E:FE:D1  
          inet6 addr: fe80::b03d:8cff:fe1e:fed1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:84299 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:7501210 (7.1 MiB)

vethf82b239 Link encap:Ethernet  HWaddr 72:87:87:30:8A:BE  
          inet6 addr: fe80::7087:87ff:fe30:8abe/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83376 errors:0 dropped:0 overruns:0 frame:0
          TX packets:172688 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5280709 (5.0 MiB)  TX bytes:72336036 (68.9 MiB)

wlan0     Link encap:Ethernet  HWaddr 06:9F:1A:A6:B1:98  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:355992 errors:0 dropped:355992 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:141303987 (134.7 MiB)  TX bytes:0 (0.0 B)