Meta-resin announcemet


#1

It’s great to hear the announcement of the open sourcing of meta-resin.

Unfortunately I can’t access the instructions linked to in the blog post. Chrome is complaining “Your connection is not private…When Chrome tried to connect to docs.resin.io this time, the website sent back unusual and incorrect credentials.”

Firefox also complains “This Connection is Untrusted…”


#2

Hey,

We’re investigating an issue where the link is being automatically converted to https on some occasions, in fact the link is valid - http://docs.resin.io/#/pages/hardware/meta-resin.md - hopefully this gives you the information you need and we’ll look into fixing this issue!

Best, Lorenzo


#3

Ok I’m glad to say we have fixed this and this shouldn’t recur!


#4

Great, now I can get in. Thanks.

Only one problem. I’m lost at the first paragraph "Pre-requisites: yocto BSP layer for your particular board. Should be compatible to yocto fido "

Do what?

So I have a bunch of ISEE IGEP v2 ARM boards, currently running Debian Wheezy from SD card. The boot loader can boot into an image on on board FLASH. I seem to recall it is something from Linaro.

What to do to get resin on there?

Sounds like I need to dedicate some time to researching this Yocto thing and it’s BSP’s


#5

Hello,

First of all thank you for your shown interest in meta-resin and devices support. Sorry for the confusion related to yocto version “fido”. Yocto releases twice per year and you can see here the ones that were already done and the next to be released. Our current yocto layers are developed for the fido version which means that all the dependencies of these layers need (or is recommended) to be based on fido (obviously, this includes poky itself).

In order to add resin support for a board, the first step is to search or develop a BSP layer. Generally a BSP layer includes kernel, bootloader, gl libraries, all being specific for that board. I searched the internet and the yocto support for the ISEE IGEP board seems to be already done but only for older releases of yocto (see here) which means there could be some time needed to be invested in order to make it work with out code or upgrade it to yocto fido.

The above mentioned support is not officially recorded as yocto layer (oe layers) so this means that is either work in progress or is just not known to yocto community (oe).

As soon as you get through these basic requirements, following the document should get you to a new supported board. Be aware though that this document is still in early beta stages so feel free to ask questions and we will support you through this new board adoption process as much as we can.

Regards,
Andrei