LibreSSL build hangs on `checking size of time_t... 4`

raspberrypi3
builder

#1

Hi seems like the ARM build hangs while building LibreSSL:

...
[Build]    checking size of time_t... 4
[Build]     ** Warning, this system is unable to represent times past 2038
[Build]     ** It will behave incorrectly when handling valid RFC5280 dates
[Info]     Still working...
[Info]     Still working...
...

Works fine on x64 builds though.

The build command in Dockerfile.template, looks like this, nothing special:

FROM resin/raspberrypi3-alpine-buildpack-deps:latest AS builder

RUN wget https://github.com/libressl-portable/portable/archive/v2.6.4.tar.gz\
  && tar -xvf v2.6.4.tar.gz\
  && cd portable-2.6.4\
  && ./autogen.sh\
  && ./configure --prefix="/usr/local/ssl"\
  && make check\
  && make install

Any ideas?


#9

Hi. We will be looking into this and come back as soon as we have something. Thank you for understanding.


#14

Any luck with this issue on the ARM build machines?


#19

@ab1 I’ve just taken a look at this issue, and the dockerfile you provided. The tweaked file below builds, evenutally. The autogen.sh takes a really long time, but then the next push uses the cached layer so don’t worry too much.

FROM resin/raspberrypi3-alpine-buildpack-deps:latest AS builder

RUN apk --update add libtool autoconf automake

RUN wget https://github.com/libressl-portable/portable/archive/v2.6.4.tar.gz\
  && tar -xvf v2.6.4.tar.gz\
  && cd portable-2.6.4\
  && ./autogen.sh\
  && ./configure --prefix="/usr/local/ssl"\
  && make check\
  && make install

CMD echo "hello world!"

#21

It started working in the last few days without any changes from my side.


#22

That is simultaneously really good and really irritating. Oh well, sometimes these things happen.