Jetson TX2 Wifi Power Save


#1

By default the TX2 WiFi with ResinOS seems to be set in power-save mode, resulting in very slow transmits and long latency.

Disabling power saving is as simple as iw dev wlan0 set power_save off but it’s annoying to have to do this on every boot during development. Is there some way to disable power saving at the OS layer?


#7

Hi,

Yes, this is something that you can achieve by configuring NetworkManager. Simply add a powersave options to the [connection] section found in your connection conf file (i.e. any file under the system-connections dir).
You can set it in 3 ways: 0 (use default), 1 (ignore/don’t touch), 2 (disable) or 3 (enable)

Here is the above applied on the resin example NetworkManager conf file:

[connection]
id=resin-wifi
type=wifi
powersave=2

[wifi]
hidden=true
mode=infrastructure
ssid=My Awesome WiFi Ssid

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=super_secret_wifi_password

Kind regards,
Theodor


#9

Hi Theodor,

Thanks for your help. On the TX2 if I manually write this on the HostOS, it seems to get overwritten on reboot. Does this need to be written in from the start? Is there a known way to disable NetworkManager powersave via DBus?


#10

Hi,
You should not modify this directly on the rootfs, but on the boot partition where your connection file resides (the same file where you configure the wireless connection).
You should be able modify powersave over DBus, but you need to inspect a bit the NetworkManager Dbus API (https://developer.gnome.org/NetworkManager/stable/spec.html) as I am not sure of the precise endpoint you need to hit.

Kind regards,
Theodor