Issue deleting application

support

#1

Hi,

We’re currently having some issues with removing 1 application. When I try to delete it it just returns with the following error :
Application not found:

But I’m in that application, and the applicationid is the same as in the URL so it’s kinda strange …

Did someone also had that issue in the past ? Is there a way to fix it ?

Thanks!


#4

Hey @Nicky I can look into this for you, could you share your application URL and enable support access please?


#5

Hey @CameronDiver

Thanks!

The url is: https://dashboard.resin.io/apps/741692/actions

and I shared support access

Thanks again!


#6

Hey @Nicky

Just as an update, I looked into this and I’ve found the specific error occuring, unfortunately I haven’t yet found the root cause for the problem. Please could you extend the support access for next week and I’ll try get to the bottom of this asap.

Thanks


#7

Hi,

Thanks for investigating the issue !!!

I extended the support access for another week!

Thanks again!


#8

Hey @Nicky

I believe we’ve found the issue, with it being related to a corner case of cascade deletions and dependent applications. This has been fixed and deployed to production so you should now be able to delete your application. Please do let us know if this is not the case!


#9

Hi @CameronDiver

I just tried to delete the application. And it worked!

Thanks !!


#10

Glad to hear! Enjoy resin :slight_smile:


#11

Hijacking this thread because I got exactly the same error today. Support access enabled, application is here

https://dashboard.resin.io/apps/424206


#12

Hi, that issue should have been fixed up already, let me check with our team.

To be clear, you are trying to delete this application, right?


#15

Yes, that is correct.


#31

Hey @russel the issue in your case seems different. You have a number collaborators added to the application, and there’s a quirk in the permission system that might block deletion in this particular case, as the devices slightly before a change that has an effect on this.

So would recommend deleting the devices (and possibly afterwards removing the collaborators from the app too), and then trying to delete the application.

Let us know if you had a chance to try it out!


#32

Success!

I deleted all devices, removed all collaborators, revoked support accesss, and then deleted the application.

Thanks for the help!


#34

Great, cheers!