Intel Nuc Debian Base Image Restarts Continuously

support

#1

I’m trying to make a container based on the resin/intel-nuc-debian:jessie image. I noticed after building out the image locally and pushing to resin that the application continually restarts itself. I stripped the Dockerfile down to one line: “FROM resin/intel-nuc-debian:jessie” and I get the following errors after pushing to resin:

81784aa17bc14b19a7'
19.06.17 14:08:01 (-0500) Application exited 'registry2.resin.io/printserver/8a922f4b94df1254b421d08178
4aa17bc14b19a7'
19.06.17 14:08:02 (-0500) Restarting application 'registry2.resin.io/printserver/8a922f4b94df1254b421d0
81784aa17bc14b19a7'
19.06.17 14:08:03 (-0500) Application exited 'registry2.resin.io/printserver/8a922f4b94df1254b421d08178
4aa17bc14b19a7'```

So on and so forth...
I'm definitely pushing this image to an Intel Nuc.

Is this a bug?

#3

I went down a layer to grab the “resin/amd64-debian:jessie” image.
It restarts but now gives me some helpful info:
/bin/bash: /start: No such file or directory
Looks like I have to make a start script.


#4

Made a start script:

#!/bin/sh
echo "okay it's running"

The application still continually restarts in Resin:

0b16890c502a37'
19.06.17 14:40:47 (-0500) Restarting application 'registry2.resin.io/printserver/c2a94c7fe4a933b1e62405
9d3f0b16890c502a37'
19.06.17 14:40:40 (-0500) okay it's running
19.06.17 14:40:40 (-0500) okay it's running
19.06.17 14:40:41 (-0500) okay it's running
19.06.17 14:40:42 (-0500) okay it's running
19.06.17 14:40:43 (-0500) okay it's running
19.06.17 14:40:47 (-0500) Application exited 'registry2.resin.io/printserver/c2a94c7fe4a933b1e624059d3f
0b16890c502a37'
19.06.17 14:40:53 (-0500) Restarting application 'registry2.resin.io/printserver/c2a94c7fe4a933b1e62405
9d3f0b16890c502a37'
19.06.17 14:40:40 (-0500) okay it's running
19.06.17 14:40:40 (-0500) okay it's running
19.06.17 14:40:41 (-0500) okay it's running
19.06.17 14:40:42 (-0500) okay it's running

#6

When you say that you were building the image locally, were you also running it locally successfully?

I’m curious why you’re installing hypriot’s Docker. Are there patches there you’re looking for? I’m assuming you’re working on a docker-in-docker project.


:speech_balloon:


#8

Hypriot’s Docker was a mistake on my part, I pasted the Dockerfile from another source and didn’t remember to change over to Docker’s Intel build.
That doesn’t seem to be the issue though; now that I’ve installed the correct Docker build, my application continuously restarts on the Resin device. It restarted this same way with a basic echo script in /start as well.


#9

Would you mind sending the link to your device to pm@resin.io so I can take a look?


:speech_balloon:


#10

Sent :thumbsup: and thank you