Installing omxplayer & chromium-browser on debian stretch


#1

Hey - i’m trying to install ‘omxplayer’ & ‘chromium-browser’ on a Raspberry PI 3. My Dockerfile.template contains the following:

FROM resin/%%RESIN_MACHINE_NAME%%-debian:stretch

RUN apt-get update &&
apt-get -y install build-essential cron git-core net-tools python-netifaces python-simplejson python-imaging python-dev sqlite3 libffi-dev libssl-dev curl psmisc matchbox omxplayer x11-xserver-utils xserver-xorg chromium-browser htop nload cec-utils mediainfo &&
apt-get clean &&
rm -rf /var/lib/apt/lists/*

I’m getting the errors ‘unable to locate package omxplayer’ but seems weird as the raspbian repository is loaded. Any ideas?

Output:
[Build] Reading state information…
[Build] Package chromium-browser is not available, but is referred to by another package.
[Build] This may mean that the package is missing, has been obsoleted, or
[Build] is only available from another source

Works on FROM resin/%%RESIN_MACHINE_NAME%%-debian, but would prefer to use stretch.

Thanks!


#6

Hi,

The packages are missing since the raspbian repository in stretch is not pulled. You can add it by doing echo "deb http://archive.raspberrypi.org/debian jessie main" >> /etc/apt/sources.list.d/raspi.list \ && apt-key adv --keyserver pgp.mit.edu --recv-key 0x82B129927FA3303E then do apt-get update again. However, I just check and omxplayer can’t be installed since it has a broken dependency on stretch (libssl1.0.0) so I think it’s better if you stay with jessie or you need to manually install omxplayer on stretch.