How can I configure my resinified raspberry for a touchscreen use?

raspberrypi3

#1

Hi there

I want to use a little screen with my raspberry, but I need to set the size correctly.
I should enter this into a config.txt

Full documentation on this: https://learn.adafruit.com/adafruit-5-800x480-tft-hdmi-monitor-touchscreen-backpack/raspberry-pi-config

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (here we are forcing 800x480!)
hdmi_group=2
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0
hdmi_drive=1

max_usb_current=1
    
# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt

I just pushed this config.txt to the raspberry via resin. But it does not change anything. Is this even the correct config.txt?
Or where does it have to go?

Additionally: I want to force the raspberry to output Audio via the 3.5mm Jack and not via HDMI. Normally I would just use raspi-config on normal raspberry, but on a resinified raspberry I am not able to do that.

Thanks in advance

Cheers

J

-------- Edit:

I think I acutally managed to force audio to the jack instead of HDMI by adding

amixer cset numid=3 1

to the config.txt file. So I assume the raspi-config is only available by writing the flags into the config.txt.

But anyway, I still did not manage to get the screen to work… If someone sees an important thing I am overseeing, please feel free to tell me :).


#4

Does this blog post help? https://resin.io/blog/updating-config-txt-remotely/


#5

I’ll try some things. Thanks for the link so far. I’ll keep you posted if I achieve what I want.
Cheers