Ffmpeg broken package?

alpine

#1

Recently, ffmpeg in Alpine/RaspberryPi seems to have broken. Can anyone suggest a workaround?

Step 26/49 : RUN apk add ffmpeg
 ---> Running in 82c5f70420b1
ERROR: unsatisfiable constraints:
  so:libx265.so.160 (missing):
    required by:
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]
                 ffmpeg-libs-3.4.4-r0[so:libx265.so.160]

My Dockerfile contains:

FROM resin/raspberrypi3-alpine
RUN apk update
RUN apk add ffmpeg

#4

Hi,

I tried the official alpine image (arm32v6/alpine:3.8) and had the same issue so there’s something wrong with the ffmpeg package on armhf Alpine Linux(I don’t have this issue on x86 or x86_64).

So the workaround here is changing the base image to resin/raspberrypi3-alpine:3.7 which doesn’t have this issue until it’s fixed upstream.