`env INITSYSTEM on` not working

systemd

#1

We have a simple dockerfile, similar to:

FROM resin/armv7hf-debian
ENV INITSYSTEM on
CMD /app/start.sh

However, this does not cause systemd to start as expected.

Exposing this device to the environment variable INITSYSTEM on via Resin.io does however make it start.

Why is this and what’s the difference?


#3

Hi @niklasnorin

I just pushed the dockerfile you posted and got this in the logs, it looks like systemd is enabled to me. Do you not see the same logs or expect a different output?

15.08.17 17:04:17 (+0100) Systemd init system enabled.
15.08.17 17:04:18 (+0100) systemd 215 running in system mode. (+PAM +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ -SECCOMP -APPARMOR)

#6

Hey @niklasnorin, did you ever get to the bottom of this?


#7

I’ve actually not had time to look into it since we found a workaround. I’ll update this thread when I’ve had the time to take a look again.

Thanks for checking in :slight_smile:


#8

Great, let us know if you find anything interesting :slight_smile:


#10

Hi
The reason for this issue is that we are building the container using “resin build --emulated” in our own jenkins setup, and there it seems then that the INITSYSTEM is not added as env. I.e like:

We’re still seeing this issue (we have resolved it temporarily by setting INITSYSTEM via the resin dashboard), and are interested in figuring out how to resolve it in our build system.

Any hints (we’re runing resin cli 6.13.3)?


#12

We believe this issue to be fixed in v6.13.4 of resin-cli. Would you mind giving it a try and letting us know here if it’s still a problem.