Devices are not updated after push


#1

Hi,
For some reason the build are ok but devices are not being updated.
It’s possible to force deployment on devices?

Thanks


#2

Hi @jmzuazo, we’ll need a bit more information to understand what may be going wrong.
What resinOS version do your devices have? Does your app use update locking? Have you moved the devices over from another application?

Can you describe the behavior you’re seeing? You push, see the unicorn, and then nothing happens? Or do you see any error logs?
(Might be a silly question, but have you double checked you’re pushing to the git remote that corresponds to the application in which your devices are provisioned?)


#3

Hi @pablo,

  1. Resin OS 1.24.1 (Intel Edison)
  2. No, is a fresh app with default settings
  3. No

I think maybe the problem was that I used SourceTree to push the changes and the “push all tags” option was selected on the first push, after unicorn I saw an error about the tags.
After pushing other changes (without selecting the “Push all tags” option, the process ended successfully and without errors but the devices were not updated.
I check the builds logs on the resin.io dashboard and there are no errors there either.

After that, I create a new application and push the changes without selecting the “Push all tags” option and the devices were updated correctly.

Tell me if you want me to redo the steps that generated the problem to see if it was actually generated when trying to push the tags.

Thanks


#4

Hello,
yes, maybe something went wrong with the push via SourceTree. Haven’t used it myself, so I don’t know exactly what might went wrong. Actually all you need is to git push resin master. So maybe SourceTree performed some additional actions?


#5

Hi,

I think try to push the tags was the problem.