Device service variables are out of sync


#1

Hi, for some reasons the service variables that I override on a specific device doesn’t restart the app anymore and aren’t reflected when I do a printenv on the box. This seems to be a new bug as everything was working ok on other applications the last few days.

Adding new variables seem to work though. I’ve enabled support access, you should see that I’ve setup a device variable called HDD_MOUNT but is not reflected on the device itself after a restart or a reboot.


#4

Confirm!
Some of my devices not reacting on service and device variables change. Found this yesterday on at least two of my devices
This is critycal for me.
I can’t set RESIN_SUPERVISOR_LOG_CONTROL to “false” on bandwidth consumption limited devices.


#5

@letrich if you add a new variable (but still use the same name) instead of overriding then it will work, definitely a reproducible error.


#6

Hey @brice and @letrich could you guys send me a dashboard link and enable support access please? I would really like to see the devices to try and work out why this may be going on.

Thanks


#7

Hi, @CameronDiver
https://dashboard.resin.io/devices/cc0da3316df834654994c4b66fbce57c/
I set access to 12hrs. Right now I can see logs while RESIN_SUPERVISOR_LOG_CONTROL set to Disable
Moreover, this variable was set earlier and there were no logs
Another device with the same issue:
https://dashboard.resin.io/devices/452bd94df00419a836865ca6d7b8c24d/


#8

Hey @letrich thanks for sharing your device. I’ve managed to reproduce, and I will be working on a fix today. I will update this thread when it has been merged.


#9

Hi @CameronDiver
Please note, i have the same issue on other applications.
Tell me If you need to extend access time
Alex


#10

@letrich it seems like this was caused by an overactive load balancer on our backend, caching results longer than they should have been. This has been fixed, so you should be good to go.

Does it look ok from your side?


#11

Hi @CameronDiver,
Seems the problem still there.
I can see logs while LOG_CONTROL disabled. Change this variable to enable and disable again helps for a while but i can see logs again on next day.
I make access for 1 day for one device:
https://dashboard.resin.io/devices/cc0da3316df834654994c4b66fbce57c/
You can enable vpn if you need
Best regards,
Alex


#14

Problem not solved. The logs are still appearing in resin even if we change “RESIN_SUPERVISOR_LOG_CONTROL” different times and getting confirmation from device.