Device not connecting when moved to location with different network setup


#1

I am facing a network connectivity issue with my Raspberry Pi 3 running ResinOS. I work at our main office location and I had completely set up a device in ResinOS to run Screenly (digital signage software). This worked perfectly. However, this device was intended for a different location. I had someone who was going there take it and install it. The device booted to the ResinOS logo just fine, but then showed a “this page cannot be displayed” message. I logged into the ResinOS dashboard and saw that the device was not connecting and was still showing the old office IP address. There are DHCP servers enabled in the firewalls at all of our locations, so it should be getting a valid IP address. Does Resin lock the initial IP address to the device? I have no way to remotely access this device, so I am having it brought back to me. Please assist. Thank you!


#4

The IP address is always acquired through DHCP. You see the old IP on the dashboard, since the device has not established a VPN connection to our servers in the new location, thus the information is not updated on the dashboard.

There are a couple of options to diagnose this further:

  1. You can plugin in a USB cellular dongle to the device on the new location, so that connectivity is established through it. Then we may assist you in investigating why the device does not connect through the local network.
  2. You may install this script on the host OS: https://github.com/resin-io-playground/nm-debug-logs, so that logs are retrieved in the data partition and you may send them to us for further inspection. However this could be problematic if you have to bring the device back and forward to your office location.

#6

The person installing the device in bringing it back to the office for further investigation. When it gets back here, I will first test to see if it connects to the Resin servers from here. Then I will look at the verbose logger script you mentioned. Thank you for your response!


#7

Sounds good. Please let us know how that goes further.