Can't access supervisor API, environment variables are missing


#1

Hello

I created a Starter device, with docker-compose and 3 services. Services use INITSYSTEM. None of the services see any supervisor environment variables like RESIN_SUPERVISOR_ADDRESS or RESIN_SUPERVISOR_API_KEY.

We are using:

OS: Resin OS 2.13.1+rev1production
supervisor version: 7.11.0
platform: Intel NUC

How come we don’t see these supervisor environment variables

Thanks so much
Peter


#3

Btw. we are building the services from this image: resin/intel-nuc-buildpack-deps:jessie


#4

Hi,
Can you please send us the link to your devices and grant support access, so we can troubleshoot this issue?
To grant access: navigate to that app or device, find Actions in the sidebar, click “Grant support access”.

Kind regards,
Thodoris


#7

Please also double check that you are setting the io.resin.features.supervisor-api label and network_mode:host is enabled on the services that need access to the supervisor API.

Here is a link to our docs on the available labels:



#10

Just to clarify what Thodoris said - you’d only need to enable the io.resin.features.supervisor-api label (set it to “true”).

Changing the network_mode shouldn’t be necessary, but it would work well too as long as the label is set.


#11

Thanks @pcarranzav. Works like a charm :slight_smile:

Could you guys please link the label part of the docs from the environment variables? I was only reading the environment variables, and didn’t know I had to deal with labels as well.

Thanks
Peter