Artik 7 Flashing Issues


#1

I’m trying to flash Resin on an Artik 710 dev board. I’ve been following the instructions on https://docs.resin.io/artik710/cpp/getting-started/ but after setting the dip switches and powering on the board, I’m never seeing the device show up on the dashboard.

I connected a usb cable to the debug port, rebooted, and see this on boot:

U-Boot 2016.01 (May 15 2017 - 20:50:10 +0000)

Model: Samsung artik710 raptor board based on Nexell s5p6818

Board: ARTIK710 Raptor
DRAM:  896 MiB
HW Revision:    6
MMC:   NEXELL DWMMC: 0, NEXELL DWMMC: 1
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
LCD#1:0x4, LCD#2:0x4, CAM#1:0x4, CAM#2:0x4
ADD-ON-BOARD : 0xFFFE
Net:   
Warning: ethernet@c0060000 (eth0) using random MAC address - 9e:d8:50:57:17:84
eth0: ethernet@c0060000
Hit any key to stop autoboot:  0 
Scanning MMC and USB devices 0 1 2
** Unrecognized filesystem type **
** Unrecognized filesystem type **
reading resin-image-flasher
24 bytes read in 6 ms (3.9 KiB/s)
Found resin flasher on mmc 1
Loading resinOS_uEnv.txt from mmc device 1 partition 1
reading resinOS_uEnv.txt
** Unable to read file resinOS_uEnv.txt **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
** Unrecognized filesystem type **
Bad Linux ARM64 Image magic!
artik710#

I’ve tried flashing my sd card with both dd and Etcher and get the same result. The sd card is a Samsung Ultra 32 gig.

Any ideas on why this is happening?


#3

I’ve never provisioned a Artik7 myself but I think my colleagues can share some insights here. @shaunmulligan, @telphan have you ever had this issue?


#5

Hello @bmiller,

Would you be able to try another SD card? As well, what version of OS are you trying to flash?

Andrei


#6

Also, what is the hardware revision of your Artik710 board?


#7

Thanks for the replies! I just tried another sd card, no luck.

The resin version is 2.0.4+rev2-dev-v4.2.2

Hardware revision of the board is DH001-1.0


#8

Hm, that is strange. We you able to run anything else on this particular board?


#9

I just downloaded the factory image (A710_OS_2.0.0-sdfuse.img) and tried to re-install it. Everything seemed to go ok installing that image.


#10

Thanks for the info. I shall be checking it out again next week when I plan to update the OS for the artik710 to version 2.0.7 so keep you in the loop


#11

Sounds good, thanks!


#13

Hi @bmiller version v2.0.8+rev1 is available for download now.
Can you give this new version a try and let us know if it works for you?


#14

Thanks @floion, No issues flashing v2.0.8+rev1.


#15

You are welcome. Glad it is working as expected now